Author Topic: URS4 ECU  (Read 9256 times)

0 Members and 1 Guest are viewing this topic.

Offline portmanteau

  • #
  • *
  • Posts: 1190
  • mediator between head and hands must be the heart
Re: URS4 ECU
« Reply #40 on: June 05, 2020, 10:46:23 am »
I think you are about to hear a number of opinions about whether your guy should be going anywhere near other peoples' cars, and all of those opinions will be valid
'94 S2 Avant N300 Nothelle, '94 S2 Sedan '84 urq,'80 Golf GTI replica, '83 Rocco GTI, '99 TT, '07 Q7, '99 S4 Avant, '86 90Q, '63 DKW Junior, other non-VAG collectibles, & 2 lonely 200Q

Offline user2154

  • **
  • **
  • Posts: 314
Re: URS4 ECU
« Reply #41 on: June 05, 2020, 06:47:08 pm »
Stock AAN ECU US$350 (these are from the USA so will be from a manual transmission vehicle).

Item 5 on the list.

https://forums.quattroworld.com/classifieds-parts/msgs/54261.phtml

I have a manual ECU in my auto and it works fine but it is chipped with PRJ chips. It is a later model IMMO ECU so you have to chip it to get around the IMMO function. Maybe a non IMMO manual ECU will work in a non IMMO auto vehicle with no chips? I do not know.

I don't know if the chips are auto or manual specific, my guess is any chipped ECU will work in an auto but YMMV. Do you have an auto or a manual transmission? It worked for me and it worked another, see post #7 in this thread.

https://www.s2forum.com/forum/technical/engine-and-turbo/86467-will-urs6-ecu-work-in-my-urs4-automatic


Another chipped manual ECU

https://forums.quattroworld.com/classifieds-parts/msgs/55833.phtml


« Last Edit: June 05, 2020, 06:58:06 pm by user2154 »

Offline URS4 Avant

  • Posts: 35
Re: URS4 ECU
« Reply #42 on: June 05, 2020, 10:45:36 pm »
My car is a 6spd manual, 1993 with no immo. Thank you for the links, you seem to have a good nose for the right parts! I will still get the ecu specialist to check my ECU first, then if that fails chase one of these guys for a replacement. Mine is weird, when i turn the key i can still hear all the item clicking under the bonnet (n75, icv etc) like it did before, checked in the weekend and the G40 sensor flashes a led when wired of the plug. Fuel pump comes on and injectors fire just has no spark. So maybe something minor.

Offline user2154

  • **
  • **
  • Posts: 314
Re: URS4 ECU
« Reply #43 on: June 06, 2020, 09:04:17 am »
My car is a 6spd manual, 1993 with no immo. Thank you for the links, you seem to have a good nose for the right parts! I will still get the ecu specialist to check my ECU first, then if that fails chase one of these guys for a replacement. Mine is weird, when i turn the key i can still hear all the item clicking under the bonnet (n75, icv etc) like it did before, checked in the weekend and the G40 sensor flashes a led when wired of the plug. Fuel pump comes on and injectors fire just has no spark. So maybe something minor.


According to the US forum the ECU ignition coil driver is NLA so it doesn't sound good if you have no spark. This is the demise of a lot of ECU's apparently.

Maybe you get lucky and it is just a broken trace. Would be interested to know what was wrong if they can fix it.

https://forums.quattroworld.com/s4s6/msgs/363346.phtml



Chipped ECU's normally go for about US$500 I think. Or buy a non-chipped ECU and get them to ship it to this guy in the US to chip it before sending it over. That's the way I would go.

http://www.efiexpress.com/catalog/






Offline user2154

  • **
  • **
  • Posts: 314
Re: URS4 ECU
« Reply #44 on: February 01, 2021, 03:53:30 pm »
Did you get this fixed?