URS4 ECU

Started by URS4 Avant, March 18, 2020, 09:50:20 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

portmanteau

I think you are about to hear a number of opinions about whether your guy should be going anywhere near other peoples' cars, and all of those opinions will be valid
'94 S2 Avant N300 Nothelle, '94 S2 Sedan '84 urq,'80 Golf GTI replica, '83 Rocco GTI, '99 TT, '07 Q7, '99 S4 Avant, '86 90Q, '63 DKW Junior, other non-VAG collectibles, & 2 lonely 200Q

user2154

#41
Stock AAN ECU US$350 (these are from the USA so will be from a manual transmission vehicle).

Item 5 on the list.

https://forums.quattroworld.com/classifieds-parts/msgs/54261.phtml

I have a manual ECU in my auto and it works fine but it is chipped with PRJ chips. It is a later model IMMO ECU so you have to chip it to get around the IMMO function. Maybe a non IMMO manual ECU will work in a non IMMO auto vehicle with no chips? I do not know.

I don't know if the chips are auto or manual specific, my guess is any chipped ECU will work in an auto but YMMV. Do you have an auto or a manual transmission? It worked for me and it worked another, see post #7 in this thread.

https://www.s2forum.com/forum/technical/engine-and-turbo/86467-will-urs6-ecu-work-in-my-urs4-automatic


Another chipped manual ECU

https://forums.quattroworld.com/classifieds-parts/msgs/55833.phtml



URS4 Avant

My car is a 6spd manual, 1993 with no immo. Thank you for the links, you seem to have a good nose for the right parts! I will still get the ecu specialist to check my ECU first, then if that fails chase one of these guys for a replacement. Mine is weird, when i turn the key i can still hear all the item clicking under the bonnet (n75, icv etc) like it did before, checked in the weekend and the G40 sensor flashes a led when wired of the plug. Fuel pump comes on and injectors fire just has no spark. So maybe something minor.

user2154

Quote from: URS4 Avant on June 05, 2020, 10:45:36 PM
My car is a 6spd manual, 1993 with no immo. Thank you for the links, you seem to have a good nose for the right parts! I will still get the ecu specialist to check my ECU first, then if that fails chase one of these guys for a replacement. Mine is weird, when i turn the key i can still hear all the item clicking under the bonnet (n75, icv etc) like it did before, checked in the weekend and the G40 sensor flashes a led when wired of the plug. Fuel pump comes on and injectors fire just has no spark. So maybe something minor.


According to the US forum the ECU ignition coil driver is NLA so it doesn't sound good if you have no spark. This is the demise of a lot of ECU's apparently.

Maybe you get lucky and it is just a broken trace. Would be interested to know what was wrong if they can fix it.

https://forums.quattroworld.com/s4s6/msgs/363346.phtml



Chipped ECU's normally go for about US$500 I think. Or buy a non-chipped ECU and get them to ship it to this guy in the US to chip it before sending it over. That's the way I would go.

http://www.efiexpress.com/catalog/






user2154

Did you get this fixed?

URS4 Avant

Hello again..!

No it did not entirely get fixed. I have bought a ECU locally with the 'F' prefix. So immo and auto I believe.

Plugged it in and the car instantly burst into life, for about 4 seconds.

Bought a cheap VAG immo emulator from ebay to try, connected to + / - and the K line under the bonnet. Cranked started then stopped again.

The ECU i purchased is socketed and is running genuine MTM software. So, and it looks like you have more history with these things than i have.. if i was to purchase a set of chips without immo software do you think i would be all good?!

Kev

89 Coupe

1991 BMW E34 535i | 1989 Nissan Skyline R32 | 1993 Nissan Skyline R33 Coupe | 1989 Audi Coupe Quattro | 1996 Audi UrS6 | 1994 BMW E34 540i Touring | 1995 Audi 80 Quattro Avant | 1993 Audi UrS4 Avant | 1999 Audi S4

user2154

#47
Quote from: 89 Coupe on April 07, 2021, 12:47:07 AM
Is this the ECU you are looking for? 4A0 907 551B

https://www.trademe.co.nz/a/motors/car-parts-accessories/audi/listing/3043661295?bof=v2KqV4Nk

551B is for Auto so is not what he is looking for but then again the 551F is also for Auto..

user2154

#48
Quote from: URS4 Avant on April 06, 2021, 03:10:34 PM
Hello again..!

No it did not entirely get fixed. I have bought a ECU locally with the 'F' prefix. So immo and auto I believe.

Plugged it in and the car instantly burst into life, for about 4 seconds.

Bought a cheap VAG immo emulator from ebay to try, connected to + / - and the K line under the bonnet. Cranked started then stopped again.

The ECU i purchased is socketed and is running genuine MTM software. So, and it looks like you have more history with these things than i have.. if i was to purchase a set of chips without immo software do you think i would be all good?!

Kev

If it fires then it is a good sign that the ECU will run the engine. The IMMO is cutting out after about 4 seconds I had the same thing installing an S6 ECU into an S4 before I chipped it. If you install new chips without the IMMO function then it should run. But you have an auto ECU in a manual, I am not sure if you need to do any other modifications, google it.

My advice is buy some chips from the USA they only have manuals over there.

Try EFI Express. https://shop.efiexpress.com/

Also google auto to manual conversion as this has been done and you should find some information about using an auto ECU in a manual.

URS4 Avant

Thanks for all the help above. I ended up swapping my mtm auto ecu with a chap on s2 forums and he sent me the ECU I needed. The S4 has been running mint ever since.

slowburn

99 B5 S4 Avant
85 coupe quattro
72 fiat 124 coupe
97 corolla wagon

user2154

Quote from: URS4 Avant on August 29, 2022, 09:57:41 PM
Thanks for all the help above. I ended up swapping my mtm auto ecu with a chap on s2 forums and he sent me the ECU I needed. The S4 has been running mint ever since.

Nice one. Hope you can afford to run it with the petrol prices right now lol.